秦皇岛汽车网

易语言点击按钮更换图片框?

      发布时间:2018-07-27 15:27

      你需要添加一个图片框或者画板,然后把需要显示的图片通过HTTP读文件或者使用本地文件,加入到图片或图片组,比如:画板1.地图=#图片 这个#图片就是你本地图片 如果你还是看不懂继续追问

      回复:

      很遗憾的告诉你,这是不行的。除非你手动把各个图片资源放到一个数组,然后才可以循环提取。比如:
      .版本 2
      .支持库 spec

      .子程序 _按钮2_被单击
      .局部变量 图片数组, 字节集
      .局部变量 i, 整数型

      ' ----手动加入图片
      加入成员 (图片数组, #图片1)
      加入成员 (图片数组, #图片2)
      加入成员 (图片数组, #图片3)
      ' ---读取图片
      .计次循环首 (3, i)
      图片框1.图片 = 图片数组 [i]
      延迟 (1000)
      .计次循环尾 ()

      回复:

      .版本 2

      .子程序 _按钮1_被单击

      .如果真 (按钮1.标记 = “”)
      图片框1.可视 = 假
      按钮1.标记 = “11”
      返回 ()
      .如果真结束
      .如果真 (按钮1.标记 = “11”)
      图片框1.可视 = 真
      按钮1.标记 = “”
      返回 ()
      .如果真结束

      回复:

      .版本 2 .子程序 _图片框1_鼠标左键被按下, 逻辑型 .参数 横向位置, 整数型 .参数 纵向位置, 整数型 .参数 功能键状态, 整数型 .判断开始 (图片框1.背景颜色 = #红色) 图片框1.背景颜色 = #白色 .默认 图片框1.背景颜色 = #红色 .判断结束

      回复:

      简单的要死啊,图片框1.图片=#(注意这个符号很重要)图片组的名字(加入资源时有个图片名字要你打)而不是的你的83551. 你又涨姿势了。

      回复:

      .版本 2 .子程序 _按钮1_被单击 图片框1.可视=真

      回复:

      图片框1.图片=图片1 图片框1.图片 = 图片1 这里错了应该是 #图片1 一定要#

      回复:

      .版本 2 .子程序 _按钮1_被单击 图片框1.图片 = { } ' 这样写就可以了

      回复:

      .版本 2 .子程序 _按钮1_被单击 .如果真 (按钮1.标记 = “”) 图片框1.可视 = 假 按钮1.标记 = “11” 返回 () .如果真结束 .如果真 (按钮1.标记 = “11”) 图片框1.可视 = 真 按钮1.标记 = “” 返回 () .如果真结束

      回复:

      _按钮1_被单击 通用对话框1.过虑器 = “图片文件|*.jpg” 如果真 (通用对话框1.打开 () = 真) 图片框1.图片 = 读入文件 (通用对话框1.文件名) --------------------------------------------------------------------- 保存看你用什么保存。可以...

      回复:

      .版本 2 .子程序 _按钮1_被单击 .局部变量 number, 整数型, 静态 number = number + 1 .如果真 (number = 20) number = 0 .如果真结束 .如果真 (number = 1) 图片框1.图片 = #图片1 .如果真结束 .如果真 (number = 2) 图片框1.图片 = #...

      上一篇:女朋友真的愿意帮我垫钱去外地生活吗,我们婚姻一辈子把,是wey把,她做什么生意呢, 下一篇:一个最简分数,如果分子加上44,分母加上55,分数大小不变,这个最简分数是多少?(怎样列式计算)

      返回主页:秦皇岛汽车网

      本文网址:http://0335car.cn/view-197199-1.html
        信息删除